3D Printers, Makers, DIY hacks, solutions and post printing tools

Created by Emil Pop on 13 April, 2018

After centuries of battles that lasted some 40 years we are winning the looser prize.

I didn't made that up, somebody else did, but that is how I feel.

So I bought a dual direct drive generic block from Amazon, made in China (where else) for sure since it came in 6 weeks, with a nice pair of Nema 17 steppers, the heat blocks, with relative wires for the heat elements, thermometers, and steppers that I had to extend by 700 mm so they can follow the Cartesian cable management snakes instead of just hanging from the ceiling.

I also had to invent, design and print a support so I can fit them on the existing trolley, remove the old extruder, it's cables, etc, all this so I can print both with elastic filament (like TPU) and with PVA support (water soluble filament) so I spare myself after printing elimination of support by hand, when I can simply take the printed block and sink it in the tub with water to get the job done.

(Part is the one on the left, Support the one on the right)

My printer came with an Arduino board MKS Gen L V1.0 from Makerbase ( or some Chinese who nicked their design, God only can tell)

Software trouble initiates here, I have installed the latest Marlin and Repetier Host available, just to avoid shit, trouble is shit does not like being avoided, always in my way somehow.

Hence I tell the Repetier in the printer settings that I have two nozzles, give them names (''part'' and ''support'') set the parameters (Y ofset 35 mm, etc.), all cool, but:

When I run the tests although Repetier shows me two nozzles, when I choose to heat them up, no matter which I pick, it is only heating up the Part nozzle who's cables are going where the initial nozzle cables were going, respectively the Nema stepper in E0 socket, Thermometer in the TM1 socket and the heater power supply in the HE 0 socket, while the newcomer that I named Support has the Stepper cable in the E1 socket as indicated, the thermometer in the TM2 socket and the heater power supply in the HE1 socket.

Weird enough if I decide to start only the Support nozzle, turns off automatically in a second, if I want to run the Part nozzle alone, it works, temp is going where set, the Nema Stepper moves as I manually command it, and it prints as single nozzle machine alright.

But totally ignores the existence of my second kit.

If I start BOTH nozzles, than it shows both nozzles going up in temperature, while in reality only the Part nozzle is going up (as constantly checked with my thermometer), and when I try to run filament commands no matter whether I run them as Part nozzle or Support nozzle they BOTH work the Part Nema Stepper motor and none even consider moving the Support Nema Stepper, in other words both choices move and heat up and read the temperature of one and the same nozzle, the one hooked in the E0 socket, He1 socket and TM1 socket, and if I swap them nothing changes, meaning all orders for both Part and Support go the the E0, TM1 and HE1 socket this time working on the other nozzle/stepper since I swap them.

Long story short, commands for both circuits go to E0/TM1/HE1 group of sockets totally ignoring the existence of the E1/TM2/HE2 group of sockets.

I bought a new Arduino board MKS Gen L V1.0 from Makerbase that came in 6 weeks from China just to realize I wasted time and money for nothing, exact same issue.

Looking on the back of the Arduino board at the circuits it is clear they are separated, than why Repetier Host sees them as one good for all, and the other one does not even exist?

Any clues?